Welcome to Soldier of Fortune Community Forums
16 Dec 2017, 20:46


View unanswered postsView active topics



Reply to topic  [ 13 posts ] 
s_khz 
Author Message
Poland

User avatar

Joined:
Thu Mar 05th, 2015
Posts: 5
Reply with quote
Does it work right for you?

when 44 the music stutters
when 48 there's no music

does everyone has that?
is there a fix ?

Changing from 22 to higher settings is like removing ear protection irl :)


05 Mar 2015, 23:49
Profile
Great Britain

User avatar

Joined:
Mon Nov 21st, 2011
Location: England
Posts: 3077
Reply with quote
Sorry for the delay in approving the post VoivoD  :(


06 Mar 2015, 20:04
Profile WWW
Great Britain

User avatar

Joined:
Fri Dec 02nd, 2011
Posts: 88
Reply with quote
I can confirm mine also bugs similarly at 44 and 48


07 Mar 2015, 12:37
Profile
Netherlands

User avatar

Joined:
Mon Jun 25th, 2012
Posts: 112
Reply with quote
VoivoD wrote:
Does it work right for you?

when 44 the music stutters
when 48 there's no music

does everyone has that?
is there a fix ?

Changing from 22 to higher settings is like removing ear protection irl :)
I also have the missing music at 48 kHz, but 44 seems ok to me. I can change the menu and add a warning to the 44 and 48 kHz setting, that music may not work. Is the sound OK at 44 and 48, or should I simply remove the 44 and 48 settings altogether?


07 Mar 2015, 22:31
Profile
Great Britain

User avatar

Joined:
Fri Dec 02nd, 2011
Posts: 88
Reply with quote
The problem for me is so minor , that there is more gained from 44hz than problems caused.  Imo don't remove it just for that, a warning would be nice, using an updated menu file with a message box somehow? :P lol kinda lame

44 khz - experimental

that could do it ?


08 Mar 2015, 13:51
Profile
Netherlands

User avatar

Joined:
Mon Jun 25th, 2012
Posts: 112
Reply with quote
d3nd3 wrote:
The problem for me is so minor , that there is more gained from 44hz than problems caused.  Imo don't remove it just for that, a warning would be nice, using an updated menu file with a message box somehow? :P lol kinda lame

44 khz - experimental

that could do it ?
Yes, I'll add a text like that.

I may also add a menu option to change s_mixahead. The default delay of 0.2 makes the sound feel quite laggy.


08 Mar 2015, 20:46
Profile
EU

User avatar

Joined:
Sun Oct 04th, 2015
Posts: 1
Reply with quote
So, I don't want to bump this, but the board seems dead and forgotten anyway.

44 KHz causes massive stuttering/broken sounds with default sound drivers, 48 KHz has no music or voices.

Please see if you can fix this.


04 Oct 2015, 20:57
Profile
Antigua & Barbuda

User avatar

Joined:
Sat Jul 23rd, 2016
Posts: 1
Reply with quote
I have same issue.
Why no one can fix that?
22khz very bad for ears.


24 Jul 2016, 14:26
Profile
Netherlands

User avatar

Joined:
Mon Jun 25th, 2012
Posts: 112
Reply with quote
Nuke142 wrote:
I have same issue.
Why no one can fix that?
22khz very bad for ears.

I hacked the support for 44 and 48 kHz into the game and 44 kHz works for me (without interruptions / pops). With 48 kHz, the music doesn't work, but that doesn't bother me. The SoF1 sourcecode isn't available, so a proper fix isn't easy. Maybe I should remove 44 kHz and 48 kHz support again, if many players are having issues with it.


02 Aug 2016, 20:36
Profile
Canada

User avatar

Joined:
Wed Nov 23rd, 2011
Location: Kanada
Posts: 572
Reply with quote
3klnk4jh wrote:
With 48 kHz, the music doesn't work, but that doesn't bother me.


It did bother me unfortunately lol :P


02 Aug 2016, 21:16
Profile
Canada

User avatar

Joined:
Sat Oct 08th, 2016
Location: Quebec
Posts: 7
Reply with quote
Sorry for popping up an old thread...

I can only select between 11KHz and 22KHz... If I select 44KHz or 48KHz it "works" in the meaning of in the option menu when I select 44KHz or 48KHz it stays on and selected, but it sounds like 11KHz.

The only option I can select and see a difference it's 22KHz.

Is there anykind of fix? Commands? Custom release? I can use to play the game at 48KHz. ?

I know the music won't play on 48KHz but it doesn't botter me in my case, otherwise I'd go at 44KHz wish isn't much a big deal.

Thank you for your help, I'll keep reading/browsing around if I can find a solution.

~Husky


16 Nov 2016, 02:28
Profile
Canada

User avatar

Joined:
Sat Oct 08th, 2016
Location: Quebec
Posts: 7
Reply with quote
Well I've found a client, but I don't know if I should get it since im using SOF1 Communauty's client :

SoFplus - Soldier of Fortune addon (aka SoF+ or SoF plus) SoFPlus 1.07f

"The sound frequency setting in the audio settings can now be changed to 11, 22, 44 and 48 kHz."

But I can already do that with the actual client, so I don't think it would solve my issue =/

I'll keep looking for solutions ;)


16 Nov 2016, 02:32
Profile
Netherlands

User avatar

Joined:
Fri May 23rd, 2014
Posts: 449
Reply with quote
SoF1 Community client = SoFplus 1.07f.
SoFplus 1.07f = SoF1 Community client.
:wacko:
SoFCE is a package/installer with the community edits, SoFplus is one of those edits.



Quote:
I can only select between 11KHz and 22KHz... If I select 44KHz or 48KHz it "works" in the meaning of in the option menu when I select 44KHz or 48KHz it stays on and selected, but it sounds like 11KHz.

After setting it to 44 & applying settings, type in console snd_restart & reload the map if one was loaded.


16 Nov 2016, 14:59
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 13 posts ] 
Topic Views: 944


Who is online

Users browsing this forum: Bing and 1 guest


Top
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Group
www.sof1.org