Welcome to Soldier of Fortune Community Forums
22 Nov 2017, 23:08


View unanswered postsView active topics



Reply to topic  [ 9 posts ] 
Anyone knows the line for sound quality? 
Author Message
Poland

User avatar

Joined:
Tue Dec 06th, 2011
Location: Poland
Posts: 75
Reply with quote
Heylo,
I've been recently experiencing some weird issue. All of sudden my sound quality became freaking poor on the launch. I need to manually enhance this setting every time I run the game, as a result. Anyone knows perhaps a line that can be put into autoexec so this doesn't happen anymore?

The really weird part is that I didn't really change anything in game settings nor in autoexec.


Attachments:

16 Jan 2016, 16:56
Profile
Netherlands

User avatar

Joined:
Fri May 23rd, 2014
Posts: 446
Reply with quote
set s_khz "44"


16 Jan 2016, 17:00
Profile
Poland

User avatar

Topic author
Joined:
Tue Dec 06th, 2011
Location: Poland
Posts: 75
Reply with quote
Sauron wrote:
set s_khz "44"


Thanks, it does work... I mean it sets sound frequency to the amount I want it to. Nevertheless, my issue is persistent and the sound is still poor. For instance I can force khz to 48 in my autoexec, but the sound quality is still freaking poor (even though the setting in settings presents the value of 48). This is so odd...

Once I set it manually by clicking the setting a few times back to 48 the sound is as it's expected to be, lol.


16 Jan 2016, 17:52
Profile
Great Britain

User avatar

Joined:
Mon Mar 16th, 2015
Posts: 422
Reply with quote
U mnie zmieniło się tak ze 22 kHz brzmi tak jak 44 powinno


16 Jan 2016, 18:09
Profile
Poland

User avatar

Topic author
Joined:
Tue Dec 06th, 2011
Location: Poland
Posts: 75
Reply with quote
maker wrote:
U mnie zmieniło się tak ze 22 kHz brzmi tak jak 44 powinno


no u mnie tak jak piszę... mogę mieć ustawienie dobre wymuszone w autoexec'u ale mimo to dalej dźwięk jest mega chujowy.


16 Jan 2016, 18:38
Profile
Netherlands

User avatar

Joined:
Fri May 23rd, 2014
Posts: 446
Reply with quote
Do the same thing as you used to do with SoF shortcut & set console 1.

C:\Program Files (x86)\Raven\SoF\SoF.exe +s_khz 44 +return
+return opens console instead main menu
+menu join for server list.


16 Jan 2016, 20:12
Profile
Poland

User avatar

Topic author
Joined:
Tue Dec 06th, 2011
Location: Poland
Posts: 75
Reply with quote
Sauron wrote:
Do the same thing as you used to do with SoF shortcut & set console 1.

C:\Program Files (x86)\Raven\SoF\SoF.exe +s_khz 44 +return
+return opens console instead main menu
+menu join for server list.


Thanks for the contribution, but this doesn't help either... anyways it's not a showstopper so I can live with it for now, lol. I'll try to reinstall the game perhaps later.

EDIT: it's some sort of an inner conflict... something autoexec / user directory related. I just installed a fresh version and it's all good as long as I keep my stuff off lol.


17 Jan 2016, 19:52
Profile
Canada

User avatar

Joined:
Wed Nov 23rd, 2011
Location: Kanada
Posts: 572
Reply with quote
Cold wrote:
Sauron wrote:
set s_khz "44"


Thanks, it does work... I mean it sets sound frequency to the amount I want it to. Nevertheless, my issue is persistent and the sound is still poor. For instance I can force khz to 48 in my autoexec, but the sound quality is still freaking poor (even though the setting in settings presents the value of 48). This is so odd...

Once I set it manually by clicking the setting a few times back to 48 the sound is as it's expected to be, lol.


of course it wont work until you do a "snd_restart" in console


17 Jan 2016, 20:15
Profile
Poland

User avatar

Topic author
Joined:
Tue Dec 06th, 2011
Location: Poland
Posts: 75
Reply with quote
Acadie wrote:
Cold wrote:
Sauron wrote:
set s_khz "44"


Thanks, it does work... I mean it sets sound frequency to the amount I want it to. Nevertheless, my issue is persistent and the sound is still poor. For instance I can force khz to 48 in my autoexec, but the sound quality is still freaking poor (even though the setting in settings presents the value of 48). This is so odd...

Once I set it manually by clicking the setting a few times back to 48 the sound is as it's expected to be, lol.


of course it wont work until you do a "snd_restart" in console


okay, LOL. I put it into my autoexec: "snd_restart" and my issue is gone. That's genious! :dancban:. Anyways... it took me a couple of tries to make this work since "snd_restard" doesn't do shit. :fp: It's still better than sending an e-mail to a customer with a line "with best retards"...


19 Jan 2016, 00:38
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 9 posts ] 
Topic Views: 577


Who is online

Users browsing this forum: No registered users and 1 guest


Top
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group
www.sof1.org